So-net無料ブログ作成
  • ブログをはじめる
  • ログイン

UPS500LXをFedora19で使う [サーバー]

 使用しているUPS500LXを、Fedora19で使おうと思いました。
 前回のFedora17で使う方法と同じ方法ではうまくいきませんでしたので、改めてこちらに記述したいと思います。


CLASSIC PRO 無停電電源装置(UPS) UPS500LX

CLASSIC PRO 無停電電源装置(UPS) UPS500LX

  • 出版社/メーカー: CLASSIC PRO
  • メディア: エレクトロニクス



 まずは、USBで接続し、lsusb でデバイス情報を確認しておきます。以下のような情報が取れます。
 Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 003: ID 0001:0000 Fry's Electronics
 

 太字の行がUPSのものです。何度か抜き差しすればわかるはずです。このデバイス情報をメモしておきましょう。

 ではインストールです。
 1.nutのインストール
  yum install nut nut-cgi nut-client
 2./etc/ups/nut.confの以下の行を修正
  MODE=standalone
 3./etc/ups/ups.confに以下の行を追加
  [ups]
  driver = blazer_usb
  port = auto
  vendorid = 0001
  productid = 0000
  subdriver = krauler
  desc = "Soundhouse UPS 500LX"
 4./etc/ups/upsd.userに以下の行を追加
  [upsmon]
  password = pass
  upsmon master
 5./etc/ups/upsmon.confに以下を追加
  MONITOR ups@localhost 1 upsmon pass master

 6./lib/udev/rules.d/62-nut-usbups.rules に以下を追加
  # Soundhouse UPS 500LX - blazer_usb
  ATTR{idVendor}=="0001", ATTR{idProduct}=="0000", MODE="664",GROUP="dialout"

 で、ここで認識しているかどうかを確認。
  blazer_usb -a ups -DDD
  upsdrvctl start ups

 うまく認識していたら、自動起動に設定
 6./etc/rc.d/rc.localに以下を追記
   /usr/sbin/blazer_usb -a ups
   /usr/sbin/upsdrvctl start
   /usr/sbin/upsd
   /usr/sbin/upsmon
  もちろん、rc-local.serviceはenableにておく

 動作確認
  upsc ups
  nut-monitor

 ACを抜いてしばらく待って、バッテリーがへると自動シャットダウンするのを確認
 ちゃんとシャットダウンすることができました。
 Fedora17とは微妙に違うのですね。

横断歩道 [雑感]

 ある日の朝、鎌倉街道の大きな横断歩道を、子供を抱っこして「ちゃんと青信号で」渡っていると、「赤信号の」車道から自転車が飛び込んできてぶつかりそうになりました。
 とっさによけて事なきを得ましたが、その時その自転車が
 「ばかやろー、何やってんだ!!」と叫んで、そのまま逃走していきました。
 ほかの渡っている歩行者もあっけにとられています。

 信号無視の自転車にどなられたのは初めてでしたので、面食らってしましました。
 今までは信号無視の自転車は、すまなさそうにするか、無視するか、言い訳するか、でしたので。(どちらにせよ止まりませんが)

 中河原駅付近の車道を走る自転車は、原則として信号を守らないので、注意が必要です。
nice!(0)  コメント(0)  トラックバック(0) 
共通テーマ:日記・雑感

CPU温度 [サーバー]

 最近配信サーバーの調子が悪くなってきました。
 突然処理が遅くなってしまうのです。いろいろとログを調べたのですが、「遅くなる」という現象以外の原因はわかりませんでした。
 で、やむなくサーバーをばらしてみると、稼働中にもかかわらず、あろうことかCPUファンが止まっているではありませんか。さっそくCPU温度を確認してみると、102℃などといった恐ろしい値が表示されています。あーー、よくこれで動いていたなぁ。ATOM 330って、100℃超えていても壊れずに動くんだ、と感心してしまいました。
 さすがにこれではまずいので、新しいサーバーを作って入れ替えました。今度のサーバーはCore i3-2100Tで、45℃くらいで動いています。よかった、よかった。もちろんCPUとマザー/電源/メモリ以外は同じもので再構築です。

 入れ替えてよくなったことは、
 ・温度が下がった。ATOM 330 では平常時でも60℃程度、今回は102℃まで上がっていましたが、i3にしたら45℃程度です。
 ・消費電力が下がった。ATOM 330 時のシステム消費電力は27W程度でしたが、i3にしたら16W程度に下がりました。CPU自体はどちらも5%程度しか使用していません。
 ・処理速度が上がった。ATOM 330 で40秒かかっていた処理が、4秒程度で終えるようになりました。
 消費電力が下がり、温度も下がり、能力が上がったので、だいぶ良くなりました。
 っていうか、ATOM 330 ってそんなに効率悪いの? 意外と電気食いで熱くなりやすいのかな、と感じてしまいました。


 

この広告は前回の更新から一定期間経過したブログに表示されています。更新すると自動で解除されます。

×

この広告は180日以上新しい記事の更新がないブログに表示されております。